Contact

Customer Service:

laseraxe@hotmail.com

  • Black YouTube Icon
  • Black Facebook Icon
  • Black Instagram Icon
  • Black Twitter Icon
  • Black Facebook Icon
  • Black Instagram Icon
  • Black Twitter Icon
  • Black YouTube Icon

Newsletter

© 2014-2018 Laseraxe All rights reserved.

Dec 3, 2018

Laser engraver does not work, please help

2 comments

So this thing has many issues.

 

One, the laser stays on. This means, even when designing the engraving, the laser must be over the metal base. If it is not it will burn a hole in the material I am engraving. There should be a way to turn the light of the laser off while still leaving the laser itself on.

 

Two, the laser seems to be stuck. I have tightened and loosened the belts many times, made sure the bearings are oiled and still the laser makes horrible sounds like it doesn't have enough power to pull it back and forth. When I roll it manually it does seem to catch a bit.

 

Three. The software is horrid but I can use the 1.09 version. The other version crashes but if the first two start working I think I can deal with this.

I am suffering the same problem. What needs to be adjusted when the motor is stuttering and no longer moving the laser softly over the whole area?

Aug 4Edited: Aug 4

the laser should not be on all the time. I suggest there is something going wrong here. I guess you are using CNCC2019 to be using V1.09?

 

I am using CNCC2019 v1.24 and I have a push button switch on the laser itself. I can connect with the software and move around with that turned off. Even then, until I hit "Weak Spindle" or "Start" on the Engrave page then I get no laser at all.

 

Weak Spindle is just a 5% dot, then full power when I start and is handy for checking the laser's position.

New Posts